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Introduction

1.1 Introduction

28 PIN AVR Development Board helps user create and test applications using 28 PIN AVR MCUs.
The board has the basic circuit required for the AVR to function. The board can be easily programmed
using any in-circuit programmer (ISP). This features help you quickly update the program and test
again and again during the program development phase. As you do not have to remove the

microcontroller and put into the programmer each time. This greatly saves time and damages to
MCU’s pins.

You can power the board using standard 12V adaptor. The board has inbuilt regulator to provide
clean 5v to the MCU. There is also a on/off switch and power indicator LED to further ease your life.

1.2 Know your development board.

The image below show the parts on the board.

[Free Proim Area
MKE@WG’M

ConnectiProgrammerdPowerSwitchl

28 PIN AVR Development Board Overview
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Power In : Standard DC socket for powering the board. Use a 12v 500ma adaptor with Center
Positive pin.

On/Off Switch: Main Power Control, used to turn on/off the entire board.

ISP: This a 10 pin standard Atmel ISP. Used to connect with any ISP programmer for program
downloading.

MOSI

N/C

RESET

SCK

MISO

eXtreme Elecironics

Power Indicator: This LED indicates the power status of board.

Reset Button: Press this to reset the MCU. The program will start to execute from the beginning.
Free Proto Area: Here you can add more components to the board as required by your application.
You can then connect them to the i/o ports. The Vcc and GND are available near by to power your
extra devices. For example you may connect LEDs, Motor Driver etc in this free area.

I/0 Ports: The i/o ports of MCU is available in standard 0.1inch male headers. You may use single
PIN female to female burg wires to connect these i/o ports with other modules.
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2.1 Programming the Board.

The devboard can be easily programmed by an ISP enabled programmer like
eXtreme Burner - AVR(USB).

Our programmer comes with the software which can be easily installed with a single setup file. The
drives are built into the software so you do NOT need to install it separately.

Connect the programmer with your PC using a USB Cable. The GREEN(Power LED) on the
programmer should glow. Then connect the devboard with the Programmer by using an ISP Cable
(10 PIN FRC Cable). Power up the devboard.

Programming Arrangement.

Launch the eXtreme Burner AVR from the Desktop Icon. You will get a screen like this.
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M cXtreme Burner - AVR [NO FILES LOADED]
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Chip:ATmega32

By
Avinash Gupta,

Mode: ISP

eXtreme Burner - AVR, Main Screen

Click File->Open Flash from the menu or Open from the toolbar. Select the hex files you wish to program.

After this select proper microcontroller using the Chip Menu. Click Write->Flash.

Time
(@D 12:33:54PM
1) 12:38:54PM
| | @ 12:38:55em
1) 12:38:55PM
@ 12:33:55PM
) 12:38:55 PM
(D 12:33:55PM

() 12:38:55PM

63

Task

Found USBasp on USB Port
Powering On ...

Power On Success

Auto Detecting AVR Chip ...
Found: ATmega32

Erasing Chip ...

Chip Erased Successfuly
\Writing Flash Memory...

000050 340

| MEEDI Progress

‘Writing Flash Memory. ..

Time Elapsed: 00 MIN 02 SEC

3l |

000070 34

05 %

000080 |84

| onoasa 000

www.eXiremeElectronics. co.in

Chip:ATmega32

Avinash Gupta

Mode: ISP

eXtreme Burner - AVR, Burn Progress.
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File FRecentFiles Read ‘Write Erase Chip

\,i.-) 12:36:01PM  Writing Flash Memory...

@ 12:36:06 PM  Flash Memory Written Successfully

\i) 12:36:06 PM  Verifying Flash Memory ...

@ 12:36:24PM  Flash Memory Verification Success

d) 12:36:24PM  Powering OFF ...

@ 12:36:24PM  Power Turned Off

@12:36:24PM ALL TASKS COMPLETED SUCCESSFULY
\i,-) 12:36:24PM  Thankyou

[&] B

Idle

Progress Time Elapsed: 00 MIM _23 SEC

www eXtremeElectronics.co.in

@i [

Chip:ATmega32 Mode: ISP

eXtreme Burner - AVR, Write Success.

If everything is ok you will get a success message. If you get some error please consult the manual of the
programmer.

Copyright © 2008-2011 eXtreme Electronics. www.eXtremeElectronics.co.in



28 PIN AVR Development Board
User Manual

3.1 Development Process.

The development process with AVR is outlined below.

1.

First you should know what you are trying to make. You should have some algorithm in your mind and
clue on how the program should look. Or else you may have a ready made program, for example from
a Website or Magazine. The human readable code is written in some high level Language like C,C++,
BASIC etc. This code is called Source Code. We will use C language through out these tutorials.

You need a Text Edited to enter the Source Code and save in a computer file so these can be
processed by computer software.

Then a Compiler, which is a software that input a Source code in a syntax of some programming
language (in our case C) and generates a machine instructions for a specific machine(AVR MCU in
our case). In Microcontroller world these file are called HEX files(the extension is .HEX eg.
myprogram.hex)

After this we load this HEX file in a programmer software. We connect our programmer with PC and
then Connect the programmer with devboard. The programmer software then uploads this file to the
board, then the board will execute our program.

ISP Programmer used To Upload a HEX file.
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Chip:ATmega32 Mode: ISP

ISP Programmer used To Upload a HEX file.

3.2 Software Tools

The main software you will need are:

e AVR Studio — A GUI IDE for AVR. IDE or Intergated Development Environment help us to Enter, Edit,
Complie and Debug a program from a single software interface. This also help in project based
development, where more than one source file makes a complete project. Different source files
contains code logically divided by the function they perform.

e WinAVR - a free C compiler for AVRs. This will convert a source program written in C language to a
machine code that can be understood and executed by a machine (AVR MCU in our case).

We don't have to deal with a compiler manually. AVR Studio will take care of it.

o eXtreme Burner - AVR — This will upload the HEX file generated by the IDE/Compiler to the
microcontroller.
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You can get all the software from the folder named "Software™ in the Support Disc. It is better to install
WinAVR in root of a drive like c:\winavr or d:\winavr. Also please install WinAVR first then AVR Studio, this will
let AVR Studio detect the compiler. Now you are ready to write you first microcontroller program !!! In this
tutorial, you will learn the basic steps required for any microcontrollers based project. We will write a basic
“hello world” project, which is a simple LED blinker.

3.3 Entering and compiling code.

Start “AVR Studio” from Start Menu->All programs->Atmel AVR Tools-> AVR Studio 4 You will be presented
with a Project wizard as shown below.

emrne 0 AYR Studio 4 W

ﬁ Mew Project ‘

qu.|

Cpen ‘

Recent projects haodified
'@ C:vwvinashshy Projects\LED blink\LEDblink. aps 04-0ct-2007 12:39:39
'@ C:hvinaszhh. . AR ustfortesthustfortest aps 10-Feb-2008 14:03:04
'@ C:\avinazhity Projects'WAWE Ymotorsmotor. aps 06-Feb-2008 21:21:28
'@ C:\avinazhiy Projects\ AR \pwmbplm, aps 06-Feb-2008 13:21:57
'@ C:\awinazhh. \Projects\ @R Stdio\MJSARTYUSART ape 26-Jun-2007 08:06:49
'@ C:\avinazhh. . \Projects\avRStdio'Motor T et aps 24-bap-2007 00:43:22
'@ C:\avinazhh. \Projects\ @R Stdio\ T esth T est. aps 24-bap-2007 11:43:03
'@ C:\avinazhh. . ArRemaotehiBemoteh iR emote. aps 25 ap-2007 02:33:00
'@ C:\avinazhiMy Projects'AWR\LedBlink\LedBlink. aps 19-Jan-200817:08:36
Wer .12 480 |+ Show dialog at startup
| | LCancel Help

Fig - AVR Studio Project Wizard
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Select AVR GCC in Project type then enter a suitable project name say “hello” and select a location in you
hard disk. Then click next. Make sure that “Create initial file” and “Create folder” option is checked.

ecame o AVHR Studio 4 W
Select debug platform and device
Debug platform: Device:
JTAGICE k!l &Tmegal 63 [A]
|CE40 ATmegalBh
ICEBRD ATmegalEl
JTAG ICE ATmegalEl
A4 Simulator ATmega?560 [g]

ICE200 4T megaZbel

ATmegad23

ATmegadzh

ATmega32b0

ATmega32d [v]

Yer 412,460

<< Back | | Finizh LCancel Help

Fig - Device Selection

In this dialog box select AVR Simulator in “Debug Platform” list and select the AVR MCU depending on the

type of MCU installed on your development board, in Device list. Click finish. After that you will be presented
with an Integrated Development Environment-IDE. As shown below.
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AVR Studio - C:VAvinash\My Projectsi\DocsocAPTVCodelhellothello.c
‘[Ete] Projct Buld Edt View Tools Debug lndow Help
DEEH@S P 2RSS FR MAZARERE » s G0 E» &0 DES B
b ] BBk T " e S

AVR. GCC - x
=483 helo (defauit)
=9 Source Files
hello.c
23 Header Files
{4 External Dependencies
{3 Other Fies

B C:AAvinash\My Projects\Docs'ocAPT\Codethello\hello.c

2-Code Editor

1-Project
Area

_*ﬁﬁ.m | B ~.r..._|_ﬂinfo | C:\Avinash|My Projects|Docs \xAPT\Code | hello|hello.c
Build - X

3-Message Area

2 Buid | @ Message | TRFndin Fles | PlBreakpoints and Tracepoints
ATmega32 : tor Auto B inicoll

Fig - AVR Studio main window

This IDE will help you in editing, modifying, and compile source program. After a project is compiled it gives
you a “.hex” file ready to burn to your MCU. The main parts of the window are

e Project Area — displays all the files source and header in the current project. You can add and
remove files by the context menu of different groups like “source file” , “header files” etc. Double click
a file to open it in the editor.

e Code Editor — Here you enter and edit the files.

e Message Area — Here AVR Studio will show errors and warning generated by compile when it tries to
compile a source file.

Now copy past or type the following code in the code editor.
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#include <avr/io.h>
#include <util/delay.h>

void Wait ()
{
uint8 t i=0;
for (;1<23;1i++)
_delay loop 2(0);
}

void main ()

{
//Set PORTB1 as output

DDRB=0b00000010;

while (1)

{ //Set PBl1=High (+5v)
PORTB |=0000000010;
Wait () ;

//Set PBl=Low (GND)
PORTB&=0b11111101;

Wait ()
}
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If you don't understand the program don't worry, the next tutorial will teach you how to setup and use general purpose 10

ports in AVR.

Go to Project->Configuration Options to bring the Project option dialog.

Active Corfiguration [N S - |  Edt Configurations

|

53
sy
T

General
—
=

Indude
Directories

Libraries

g
v

Memory Settings

>

IE4

Custom Optior?)

I™ Use Extemal Makefile |

Output File Name: ~ |hsllo sf

Output Fie Directory: [default.

Device [megs32 -
Frequency: | | 16000000 bz

Optimization: | |02 hd

v Create Hex File

=i

[ Unsigned Chars (funsigned-char}

[~ Unsigned Bifislds (funsignedbifields)
[ Pack Structure Members (fpack-stuct)
[ Short Enums (fshott-enums)

I Generste Map File I Generate List File

Help

Fig - Setting CPU frequency and compiler optimization
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Enter the CPU frequency. If you are using xBoard™ or xBoard™ MINI enter 16Mhz i.e. 16000000. In addition,
select optimization as -O2. Click ok. Now you have entered the code now time to compile and build the
project. Press F7 or select Build->Build or click the toolbar button for Build active configuration. If the code
is error free AVR studio will show you the following message.

-

B awcco B0 vew | @info C:\Avinash\My Projects\Docs \xAPT\Code'hello\hello.c
Build
#® avr-cbicopy -0 ihex -R .eeprem  hello.elf helle.hex
# zvr-cbjcopy -] .eeprom --set-zecticn-flages=.eeprom="allec,load” --change-section-lma .eeprom=0 -0 ihex hellp.elf hellc.eep
® o\ WinAVR-20070525\bin\avr-ocbjcopy.exe: thers are no sections to be copied!
# o\ WinAVR-20070525 \bin\avr-objcopy. exe: --change-section-1ma ,eeprom=0x00000000 never uaed
make: ++¢ [hello eep) Error 1
| Buitd succesded with 1 Weznings... |

22 auid | @ Message | ShFnd in Fres | B Breakpoints and Tracepsints
ATmega32

Fig - Message

“Build succeed with 1 warning. Don’t worry about the one warning it is due to the fact that ANSI standard
suggest that return type of main() must be one, but for MCU platform there is no environment or operating
system that will receive this returned value. So return type of main() is void.

Now you have successfully compiled you first project, what you have got after compilation is a “.hex file”.
You can find it in a folder named “default” in you project folder. It has same name as you project, in this case
“hello.hex”

= default
Edit

File

View Favorites Tools

eBack - _\_) lﬁ /:\: Search /5 Folders v %

Address | && C:\Avinash'|My Projects\Docs\wAPT\Code \hello\default

Help

e — ]
File and Folder Tasks L |I

j Make a new folder dep hello.elf hello. hex
€N Publish this folder to
b

the Wel - =S
fad Share this folder
hello.o Makefile
e hello
\i_;d My Documents
& Shared Documents [v]
9.73 KB "4 My Computer
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3.4 Electrical Connections.

Connect a LED on PB1 (PortB bit 1) via a 330ohm resistor to GND. That means connect the anode
(+) of LED to PB1 and the cathode (-) of led to R and the other lead of R to GND.

Now you can relax and enjoy that light blinking with all that modern sophisticated technology
behind it and you first dedicated embedded program doing all the magic.

Now go on with your imagination tweak the program, modify delay and switching logic to get interesting
patterns blinking. The limit is your imagination.

Note

Note: For More information on using AVR studio see AVR GCC Plugin Help in the Help Menu
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